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Module 1: Getting Started with Excel 

Excel Structure 

Step-by-Step Instructions: 

1. Open Microsoft Excel. 

2. Observe the default workbook structure: 

• Title bar at the top 

• Ribbon below the title bar 

• Workbook area with sheets (Sheet1, Sheet2, etc.) 

• Status bar at the bottom 

Examples: 

• Open a blank workbook and save it as “MyFirstWorkbook.xlsx”. 

Practice Exercises: 

1. Open Excel and identify the title bar, ribbon, workbook area, and status bar. 

2. Save the workbook as “PracticeWorkbook.xlsx”. 

Navigating in Excel 

Step-by-Step Instructions: 

1. Use the arrow keys to move between cells. 

2. Use the mouse to click on different cells. 

3. Use Ctrl+Home to go to the top-left cell (A1). 

4. Use Ctrl+End to go to the last used cell. 

 

Examples: 

• Navigate from cell A1 to cell D10 using arrow keys and mouse clicks. 
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Practice Exercises: 

1. Open a new workbook and practice moving to different cells using the arrow 

keys and mouse. 

2. Use Ctrl+Home and Ctrl+End to navigate. 

Ribbon and Tabs 

Step-by-Step Instructions: 

1. Observe the Home, Insert, Page Layout, and other tabs. 

2. Click on each tab to see the different groups (Clipboard, Font, Alignment, etc.). 

Examples: 

• Click on the Insert tab and identify the Tables, Illustrations, and Charts groups. 

Practice Exercises: 

1. Click through each tab and note the different groups and commands. 

2. Customize the ribbon by adding the Developer tab: File -> Options -> Customize 

Ribbon -> Check Developer. 

 

Quick Access Toolbar (QAT) 

Step-by-Step Instructions: 

1. Locate the QAT above the ribbon. 

2. Click the drop-down arrow and select “More Commands”. 

3. Add frequently used commands like Save, Undo, Redo, and Print. 

  



Page 4 of 26 
 

Examples: 

• Add the Save As command to the QAT. 

Practice Exercises: 

1. Customize the QAT by adding at least three new commands. 

2. Use the added commands from the QAT. 

Dialogue Box and Task Panes 

Step-by-Step Instructions: 

1. Click the small arrow in the bottom-right corner of the Font group to open the 

Font dialog box. 

2. Explore task panes like the Format Cells pane. 

Examples: 

• Open the Font dialog box and change the font style to Bold Italic. 

Practice Exercises: 

1. Open the Font dialog box and explore different font options. 

2. Open the Format Cells task pane and apply a border to a cell. 

Customizing Ribbons and QAT 

Step-by-Step Instructions: 

1. Go to File -> Options -> Customize Ribbon. 

2. Add a new tab or group and add commands to it. 

3. Go to File -> Options -> Quick Access Toolbar and add/remove commands. 

Examples: 

• Create a new tab named “MyTab” and add the Sort & Filter command to it. 
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Practice Exercises: 

1. Customize the ribbon by adding a new group under the Home tab and adding 

commands to it. 

2. Customize the QAT by adding at least one new command and removing an 

existing one. 

Active Cell 

Step-by-Step Instructions: 

1. Click on a cell to make it active. 

2. Observe the active cell address in the Name Box. 

 

Examples: 

• Select cell B5 and observe the active cell in the Name Box. 

Practice Exercises: 

1. Click on different cells and note the active cell address in the Name Box. 

2. Use the Name Box to select cell E10 by typing “E10” and pressing Enter. 

Ctrl and Alt Shortcut Keys 

Step-by-Step Instructions: 

1. Use Ctrl+C to copy and Ctrl+V to paste data. 

2. Use Alt shortcuts to access ribbon commands (e.g., Alt+H for Home tab). 

Examples: 

• Copy data from cell A1 to B1 using Ctrl+C and Ctrl+V. 

• Access the Home tab using Alt+H. 
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Practice Exercises: 

1. Use Ctrl+C to copy and Ctrl+X to cut data, then paste it using Ctrl+V. 

2. Use Alt shortcuts to navigate to different tabs and commands. 
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Module 2: Data Entry, Editing, and Formatting 

Data Entry 

Step-by-Step Instructions: 

1. Click on a cell and start typing. 

2. Press Enter to move to the next cell below, or Tab to move to the next cell to the 

right. 

Examples: 

• Enter “Hello” in cell A1 and “World” in cell B1. 

Practice Exercises: 

1. Enter your name in cell A1 and your age in cell B1. 

2. Enter a series of numbers from 1 to 10 in cells A1 to A10. 

Modifying Cell Content 

Step-by-Step Instructions: 

1. Double-click a cell or press F2 to edit its content. 

2. Make changes and press Enter to save. 

Examples: 

• Change “Hello” in cell A1 to “Hi”. 

Practice Exercises: 

1. Edit the text in cell A1 from “Hello” to “Welcome”. 

2. Change the number in cell A2 from 1 to 100. 
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Deleting Data 

Step-by-Step Instructions: 

1. Select the cell(s) you want to delete. 

2. Press the Delete key or right-click and choose “Clear Contents”. 

Examples: 

• Delete the content of cell B1. 

Practice Exercises: 

1. Delete the data in cells A1 to A5. 

2. Clear the contents of a range of cells (e.g., B1 to B10). 

Replacing Data 

Step-by-Step Instructions: 

1. Use Ctrl+H to open the Find and Replace dialog box. 

2. Enter the data to find and the data to replace it with, then click “Replace All”. 

Examples: 

• Replace “Hello” with “Hi” in the worksheet. 

Practice Exercises: 

1. Replace all instances of “1” with “One” in the worksheet. 

2. Use Find and Replace to change “2023” to “2024”. 

Editing Data 

Step-by-Step Instructions: 

1. Click on a cell to select it. 

2. Start typing to replace the current content, or double-click/F2 to edit it. 
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Examples: 

• Edit the content of cell A1 from “Hi” to “Hello World”. 

Practice Exercises: 

1. Edit the text in cell B2 to include an additional word. 

2. Change the number in cell C3 to a new value. 

Introduction to Autofill 

Step-by-Step Instructions: 

1. Enter data in a cell (e.g., “January”). 

2. Drag the fill handle (small square at the cell’s bottom-right corner) to autofill 

adjacent cells. 

Examples: 

• Enter “1” in cell A1 and drag the fill handle down to create a series from 1 to 10. 

Practice Exercises: 

1. Autofill the days of the week starting from “Monday” in cell A1. 

2. Create a series of numbers from 1 to 20 using the Autofill feature. 

Introduction to Number Formatting 

Step-by-Step Instructions: 

1. Select a cell or range of cells. 

2. Use the Number group on the Home tab to apply formatting (e.g., Currency, 

Percentage). 

Examples: 

• Format cell A1 as Currency. 
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Practice Exercises: 

1. Format a range of cells as percentages. 

2. Change the number format of cells in column B to Currency. 
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Module 3: Data Formatting 

Accessing Formatting Tools 

Step-by-Step Instructions: 

1. Go to the Home tab. 

2. Use tools in the Font, Alignment, and Number groups. 

Examples: 

• Change the font size of cell A1 to 14. 

Practice Exercises: 

1. Bold the text in cell A1 and change its color to blue. 

2. Center aligns the text in a range of cells. 

Formatting Tools 

Step-by-Step Instructions: 

1. Use the Font group for text formatting (Bold, Italic, Underline). 

2. Use the Alignment group for text alignment (Left, Center, Right). 

Examples: 

• Apply bold and italic formatting to the text in cell B2. 

Practice Exercises: 

1. Change the font color of a range of cells to red. 

2. Apply a border around a set of cells. 

Format Painter 

Step-by-Step Instructions: 

1. Select a cell with the desired formatting. 
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2. Click on the Format Painter in the Home tab. 

3. Click on the cell(s) where you want to apply the formatting. 

Examples: 

• Copy the formatting from cell A1 to B1 using Format Painter. 

Practice Exercises: 

1. Apply the formatting from cell A2 to cells A3 to A5 using Format Painter. 

2. Use Format Painter to apply the formatting of one range to another. 

Named Styles 

Step-by-Step Instructions: 

1. Go to the Home tab and find the Styles group. 

2. Click on a style to apply it to the selected cell or range. 

Examples: 

• Apply the “Heading 1” style to cell A1. 

Practice Exercises: 

1. Apply the “Title” style to cell B1. 

2. Use the “Good” style to highlight cells with positive values. 
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Module 4: Working with Cells and Ranges 

Cell Address Nomenclature 

Step-by-Step Instructions: 

1. Understand that columns are labeled with letters (A, B, C, etc.) and rows with 

numbers (1, 2, 3, etc.). 

2. The intersection of a column and a row gives the cell address (e.g., A1, B2). 

Examples: 

• Identify the address of a specific cell in a screenshot. 

Practice Exercises: 

1. Write down the addresses of three different cells. 

2. Find and select cell C5. 

Selecting Cell/Range 

Step-by-Step Instructions: 

1. Click on a single cell to select it. 

2. Click and drag to select a range of cells. 

3. Use Shift+arrow keys to expand selection. 

Examples: 

• Select the range A1 to C3. 

Practice Exercises: 

1. Select cell A1 and then expand the selection to C3 using Shift+arrow keys. 

2. Select a range of cells using the mouse. 
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Copying and Moving Cells/Ranges 

Step-by-Step Instructions: 

1. Select the cell/range. 

2. Use Ctrl+C to copy or Ctrl+X to cut. 

3. Select the destination cell and use Ctrl+V to paste. 

Examples: 

• Copy the content of cell A1 to cell B1. 

Practice Exercises: 

1. Copy the range A1 to A5 and paste it to C1 to C5. 

2. Move the range B1 to B5 to D1 to D5. 

Paste Special 

Step-by-Step Instructions: 

1. Copy the cell/range. 

2. Right-click the destination cell and choose “Paste Special”. 

3. Select the desired option (e.g., Values, Formats). 

Examples: 

• Copy cell A1 and use Paste Special to paste only the value into cell B1. 

Practice Exercises: 

1. Use Paste Special to paste the format of a cell without the content. 

2. Copy a formula and use Paste Special to paste only the formula result. 
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Select Special Cells (Go To Special) 

Step-by-Step Instructions: 

1. Press Ctrl+G or F5 to open the Go To dialog box. 

2. Click “Special” and choose the type of cells to select (e.g., Blanks, Constants). 

Examples: 

• Select all blank cells in a range. 

Practice Exercises: 

1. Use Go To Special to select all cells with formulas in a worksheet. 

2. Select all blank cells in a column. 

Using Find and Replace to Select Cells 

Step-by-Step Instructions: 

1. Press Ctrl+F to open the Find dialog box. 

2. Enter the text/data to find and click “Find All”. 

3. Select the found cells. 

Examples: 

• Find all cells containing the word “Total” and select them. 

Practice Exercises: 

1. Use Find to locate all instances of a specific number and select those cells. 

2. Use Replace to change all instances of “2023” to “2024”. 
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Adding Comments to Cells 

Step-by-Step Instructions: 

1. Right-click the cell and choose “Insert Comment” or “New Note”. 

2. Type the comment and click outside the comment box to save. 

Examples: 

• Add a comment to cell A1 saying “Important data”. 

Practice Exercises: 

1. Add comments to three different cells explaining their content. 

2. Edit and delete a comment in a cell. 

Quick Analysis 

Step-by-Step Instructions: 

1. Select a range of data. 

2. Click the Quick Analysis tool icon that appears. 

3. Choose from options like Formatting, Charts, Totals, Tables, Sparklines. 

Examples: 

• Use Quick Analysis to create a chart from a data range. 

Practice Exercises: 

1. Use Quick Analysis to add conditional formatting to a range of cells. 

2. Create a total for a column of numbers using Quick Analysis. 
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Module 5: Managing Worksheets 

Navigating Through Worksheets 

Step-by-Step Instructions: 

1. Use the worksheet tabs at the bottom to switch between sheets. 

2. Use Ctrl+Page Up/Page Down to move between worksheets. 

Examples: 

• Navigate from Sheet1 to Sheet2 using worksheet tabs. 

Practice Exercises: 

1. Use Ctrl+Page Down to navigate through all sheets in a workbook. 

2. Rename a worksheet by double-clicking its tab. 

Changing Worksheet Name and Color 

Step-by-Step Instructions: 

1. Right-click the worksheet tab and choose “Rename”. 

2. Type the new name and press Enter. 

3. Right-click the tab again and choose “Tab Color” to change its color. 

Examples: 

• Rename Sheet1 to “Data” and change its tab color to blue. 

Practice Exercises: 

1. Rename three worksheets and assign each a different tab color. 

2. Change the tab color of an existing worksheet. 
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Adding/Deleting and Hiding/Un-hiding Worksheets 

Step-by-Step Instructions: 

1. To add a worksheet, click the “+” icon next to the sheet tabs. 

2. To delete, right-click the tab and choose “Delete”. 

3. To hide, right-click and choose “Hide”; to unhide, right-click any tab and choose 

“Unhide”. 

Examples: 

• Add a new worksheet and name it “Summary”. 

Practice Exercises: 

1. Add two new worksheets and delete one. 

2. Hide a worksheet and then unhide it. 

Moving and Copying Worksheets 

Step-by-Step Instructions: 

1. Right-click the worksheet tab and choose “Move or Copy”. 

2. Select the workbook and position where you want to move or copy the sheet. 

3. Check “Create a copy” to copy instead of moving. 

Examples: 

• Move Sheet1 to the end of the workbook. 

Practice Exercises: 

1. Copy a worksheet within the same workbook. 

2. Move a worksheet to a different position in the workbook. 
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Worksheet Views 

Step-by-Step Instructions: 

1. Go to the View tab. 

2. Choose from Normal, Page Layout, or Page Break Preview. 

Examples: 

• Switch to Page Layout view to see how the sheet will print. 

Practice Exercises: 

1. Switch between Normal, Page Layout, and Page Break Preview views. 

2. Adjust page breaks in Page Break Preview. 

Saving and Opening Workbooks 

Step-by-Step Instructions: 

1. Click File -> Save As to save a workbook with a new name. 

2. Click File -> Open to open an existing workbook. 

Examples: 

• Save a workbook as “FinancialReport.xlsx”. 

Practice Exercises: 

1. Save your current workbook with a new name. 

2. Open an existing workbook and make some changes. 
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Module 6: Autofill and Custom Lists 

Autofill 

Step-by-Step Instructions: 

1. Enter data in a cell. 

2. Drag the fill handle (small square at the cell’s bottom-right corner) to autofill 

adjacent cells. 

Examples: 

• Enter “1” in cell A1 and drag the fill handle down to create a series from 1 to 10. 

Practice Exercises: 

1. Autofill the days of the week starting from “Monday” in cell A1. 

2. Create a series of numbers from 1 to 20 using the Autofill feature. 

Custom Lists 

Step-by-Step Instructions: 

1. Go to File -> Options -> Advanced. 

2. Scroll down to “General” and click “Edit Custom Lists”. 

3. Enter your list and click “Add”. 

Examples: 

• Create a custom list of department names: “HR, Finance, IT, Marketing”. 

Practice Exercises: 

1. Create a custom list of your favorite fruits. 

2. Use your custom list with the Autofill feature. 
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Module 7: Number Formatting 

Accessing Number Formatting Options 

Step-by-Step Instructions: 

1. Select the cell or range of cells. 

2. Use the Number group in the Home tab to choose the desired format (e.g., 

Currency, Date). 

Examples: 

• Format cell A1 as Currency. 

Practice Exercises: 

1. Format a range of cells as percentages. 

2. Change the number format of cells in column B to Currency. 

Number Formatting Using Dialogue Box 

Step-by-Step Instructions: 

1. Select the cell/range. 

2. Right-click and choose “Format Cells” or use Ctrl+1. 

3. Select the Number tab and choose the desired format. 

Examples: 

• Format a cell as Date using the Format Cells dialog box. 

Practice Exercises: 

1. Format cells in a column as Short Date. 

2. Change the number format of a range of cells to Scientific. 
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Custom Number Formatting 

Step-by-Step Instructions: 

1. Open the Format Cells dialog box (Ctrl+1). 

2. Go to the Number tab and select “Custom”. 

3. Enter a custom number format code. 

Examples: 

• Create a custom format to display numbers as “00000” (e.g., 1 becomes 00001). 

Practice Exercises: 

1. Create a custom format for phone numbers (e.g., (###) ###-####). 

2. Apply a custom format to display negative numbers in red. 
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Module 8: Excel Formula Basics 

Constituents of Excel Formula 

Step-by-Step Instructions: 

1. Start a formula with the equal sign (=). 

2. Use cell references, operators, and functions (e.g., =A1+B1). 

Examples: 

• Create a formula in cell C1 that adds the values of A1 and B1. 

Practice Exercises: 

1. Write a formula to subtract the value in cell B2 from A2. 

2. Create a formula to multiply the values in cells A3 and B3. 

Operators in Formula 

Step-by-Step Instructions: 

1. Use arithmetic operators: + (addition), - (subtraction), * (multiplication), / 

(division). 

2. Use comparison operators: = (equal), > (greater than), < (less than). 

Examples: 

• Create a formula in cell D1 to divide the value in A1 by B1. 

Practice Exercises: 

1. Write a formula to check if the value in A1 is greater than B1. 

2. Create a formula to add, subtract, multiply, and divide values in cells A2 and B2. 
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Entering Formula 

Step-by-Step Instructions: 

1. Click on a cell and type “=”. 

2. Enter the formula and press Enter. 

Examples: 

• Enter the formula =SUM(A1:A5) in cell B1. 

Practice Exercises: 

1. Write a formula to calculate the average of values in cells A1 to A5. 

2. Enter a formula to find the minimum value in a range. 

Editing Formula 

Step-by-Step Instructions: 

1. Click on the cell with the formula and press F2 to edit. 

2. Make changes and press Enter. 

Examples: 

• Edit the formula in cell B1 from =SUM(A1:A5) to =SUM(A1:A10). 

Practice Exercises: 

1. Edit a formula to include an additional cell in the calculation. 

2. Change a formula to use a different operator. 

Absolute/Relative Cell References 

Step-by-Step Instructions: 

1. Relative reference: A1 (changes when copied). 

2. Absolute reference: $A$1 (does not change when copied). 
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Examples: 

• Create a formula in cell C1 that uses an absolute reference to cell B1. 

Practice Exercises: 

1. Write a formula in cell C2 that uses relative references to cells A2 and B2. 

2. Create a formula in cell D3 that uses absolute references to a fixed cell. 

Copying/Pasting Formula 

Step-by-Step Instructions: 

1. Select the cell with the formula. 

2. Use Ctrl+C to copy and Ctrl+V to paste. 

Examples: 

• Copy a formula from cell A1 to cells A2 to A10. 

Practice Exercises: 

1. Copy a formula across a row of cells. 

2. Paste a formula into a different worksheet. 

Formula Auditing and Debugging 

Step-by-Step Instructions: 

1. Use the Formulas tab and choose “Show Formulas” to display all formulas. 

2. Use “Trace Precedents” and “Trace Dependents” to see the relationships between 

cells. 

Examples: 

• Use Trace Precedents to see which cells are used in the formula in cell A1. 
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Practice Exercises: 

1. Use Show Formulas to display all formulas in a worksheet. 

2. Use Trace Dependents to identify cells that depend on the value in cell B2. 

 


